Degradation of Service >> Hotel Search

Incident Report for Traveltek

Resolved

The earlier issue affecting HotelSearch for certain locations has now been resolved. Service is fully restored and functioning as expected.
We appreciate your patience and apologize for any inconvenience caused.
Posted Jun 16, 2025 - 17:04 BST

Monitoring

The earlier issue affecting HotelSearch for certain locations has now been resolved. Service is fully restored and functioning as expected.
We appreciate your patience and apologize for any inconvenience caused.
Posted Jun 16, 2025 - 16:26 BST

Investigating

We are currently experiencing some service degradation affecting HotelSearch for a few locations. Our team is actively investigating the issue and working to resolve it as quickly as possible. Thank you for your patience and understanding.
Posted Jun 16, 2025 - 15:55 BST
This incident affected: iSell London (Searches).