Apologies message - London

Incident Report for Traveltek

Resolved

The incident has been resolved. A report with further information will be provided below the incident details in due course.
Posted Jun 26, 2025 - 14:55 BST

Monitoring

A recent change has been identified as the root cause. It has been rolled back, and service has resumed.
Posted Jun 26, 2025 - 14:35 BST
This incident affected: iSell London (Databases).