Major internet services outage - Jira / Suppliers / AWS

Incident Report for Traveltek

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 10:37 BST

Update

Everyone should now be able to log in and raise tickets again following our testing, although there are still a few overall issues with Jira. Their current update following the AWS outage today is below.

"We understand the impact this issue is having on operations and want to assure you that resolving this matter is our highest priority. Our public cloud provider is actively working to mitigate this issue with urgency. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation. We will continue to provide updates every hour or sooner as new information becomes available."
Posted Oct 20, 2025 - 16:30 BST

Monitoring

Jira provided a update - "Our public cloud provider is working to mitigate this issue quickly. We are seeing some early positive indicators and are continuing to monitor." 14:15 GMT.
Posted Oct 20, 2025 - 14:23 BST

Identified

Recovery across the board is still ongoing, but many services are returning to normal status.

The Jira team is still in contact and actively working on things with the Cloud Provider (AWS).
Posted Oct 20, 2025 - 12:42 BST

Investigating

We are aware of the Amazon Web Services (AWS) outage this morning and are following up on updates from the many partners affected by it.

We have also discovered that many users are currently unable to raise tickets on Jira due to failed login pages. If you are affected and have a High or Critical issue, please reach out and email your CRM so they can raise the ticket on your behalf.

The latest update from our Partners and Amazon is recovery is under way.
Posted Oct 20, 2025 - 11:29 BST
This incident affected: iSell London (Searches, Suppliers) and iSell Dublin (Searches, Suppliers).