PCL made a fix for the Promo code issues. If you are still having any issues with the Promo Code (Farecode), please raise a ticket with the details.
Posted Nov 13, 2025 - 10:14 GMT
Monitoring
We have been informed that the Princess API issue has now been resolved. The supplier made a fix for that. We are still monitoring this at our end. As of now, all services are working fine
Posted Nov 11, 2025 - 07:20 GMT
Identified
Princess API are still working a fix on their end. Their Promo Team is still on track and are actively working to resolve it. According to Princess, you may see this issue on N** promos We'll update you for further updates.
Posted Nov 10, 2025 - 09:24 GMT
Investigating
We are currently experiencing issues with the Princess API, where some US farecodes with promotions are returning the error message: 0175-PRELIMINARY PRICING ELIGI" There are also reports of blank API response under AU market. This has been raised to the supplier, and they are investigating the issue on their end. We will provide updates as soon as more information becomes available.