CloudFlare Incident

Incident Report for Traveltek

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 09:43 GMT

Update

Update from the Cloudflare service status page

Update - We continue to see errors drop as we work through services globally and clearing remaining errors and latency.
Nov 18, 2025 - 16:46 UTC
Posted Nov 18, 2025 - 16:57 GMT

Monitoring

Update from the Cloudflare service status page

Monitoring - A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Nov 18, 2025 - 14:42 UTC
Posted Nov 18, 2025 - 14:50 GMT

Investigating

You may be aware that if you are running Cloudflare on your website, it is currently showing an "Internal server error." This is an internet-wide issue affecting customer using Cloudflare's service.

Please check and follow https://www.cloudflarestatus.com/ for updates direct from them.
Posted Nov 18, 2025 - 14:19 GMT
This incident affected: iSell Dublin (Suppliers).