Costa Booking Failures

Incident Report for Traveltek

Resolved

Costa has responded that they released a fix a few minutes ago. You may now try again on your end to book Costa cruises.
Any issues, do not hesitate to reach us via our Service Desk.
Thank you for your patience, and we sincerely apologize for any inconvenience this may have caused.
Posted Jun 13, 2025 - 15:50 BST

Update

We are currently in contact with Costa to investigate this further. We haven’t made any changes to our birth year format, yet their API is now returning an “incorrect format” error. We’re working closely with Costa to resolve this as quickly as possible and will provide further updates once we have more information.
Posted Jun 13, 2025 - 15:27 BST

Investigating

We are currently experiencing a booking failure with Costa. Our development team is investigating the issue as a top priority. We will provide further updates as soon as we have more information.
Posted Jun 13, 2025 - 15:23 BST
This incident affected: iSell London (Suppliers) and iSell Dublin (Suppliers).