Searches are not retrieving pricing - Dublin / API

Incident Report for Traveltek

Postmortem

Impact

Searches on the iSell Dublin platform were not returning any pricing information, preventing users from completing or progressing through search results.

Cause & Resolution

The issue stemmed from an unexpected database storage limitation.

During earlier maintenance to increase storage and pause replication, data continued to accumulate because the standby replica had not been fully decommissioned. This meant that historical replication logs (binlogs) were still being retained, consuming storage space even though replication was no longer active.

While steps had already been taken to fix the previous replication errors, the process encountered further issues that were not immediately visible. Once the underlying storage constraint was identified, corrective action was taken to restore database capacity and allow normal pricing retrieval to resume.

Prevention Measures

We have now properly demoted the old replica, ensuring it no longer retains unnecessary replication data. Strict expiry policies have been applied to binlogs so they are automatically cleared once obsolete. In addition, enhanced monitoring has been implemented to provide early visibility into any future storage or replication anomalies.

Posted Nov 03, 2025 - 12:10 GMT

Resolved

The incident has been resolved. Further analysis and a report will be provided in due course within the postmortem section of the incident.
Posted Oct 21, 2025 - 10:57 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 09:56 BST

Identified

The issue has been identified, and a fix is currently being implemented. The current estimated completion time for this action is 9:50 AM.
Posted Oct 21, 2025 - 09:41 BST

Investigating

We are currently investigating this issue.
Posted Oct 21, 2025 - 09:05 BST
This incident affected: iSell Dublin (Searches).