503 Service Unavailable Login Issues - London iSell

Incident Report for Traveltek

Postmortem

Impact

Customers were unable to log into the iSell platform and were shown 503 Service Unavailable errors instead of the usual login page.

Cause & Resolution

The issue was caused by our web servers reaching their maximum processing capacity (known as Max Request Workers). This happened because the servers became overloaded while waiting on responses from the database, which was affected by a separate storage issue. In effect, the web processes stopped responding as a knock-on effect of the database problem.

Our engineering team restored service by manually restarting Apache on the affected servers. The longer-term fix involved resolving the underlying storage issue on the database.

Prevention Measures

We have implemented safeguards to ensure the database cannot fill up again due to replication errors. Additional monitoring and alerting have been introduced so that any database growth or connection saturation is identified and resolved before it can impact the platform.

Posted Nov 03, 2025 - 12:08 GMT

Resolved

This incident is now resolved
If you are still experience any issues, don’t hesitate to reach out to our support team.
Posted Oct 21, 2025 - 09:27 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 09:22 BST

Update

Our team has applied a fix, and our tests show that logins are now working normally.
Please test on your end, and if you still experience any issues, don’t hesitate to reach out.
Posted Oct 21, 2025 - 09:21 BST

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 09:12 BST

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 09:04 BST

Investigating

We’re currently experiencing 503 errors when logging into the system. Our team is actively investigating the issue.
We'll keep you posted for updates
Posted Oct 21, 2025 - 09:04 BST
This incident affected: iSell London (Databases, Back-office / Front End, Scheduled Jobs, Searches, Suppliers).